aoc-2024-haskell/flake.nix

27 lines
609 B
Nix

{
description = "Advent Of Code 2024";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
};
outputs = { self, nixpkgs }: let
supportedSystems = [
"x86_64-linux" "aarch64-linux" "x86_64-linux" "aarch64-darwin"
];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
in {
devShells = forAllSystems (system: let
pkgs = nixpkgs.legacyPackages.${system};
in {
default = pkgs.mkShell {
packages = with pkgs; [
ghc
cabal-install
haskellPackages.haskell-language-server
];
};
});
};
}